about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-13T16·42+0200
committerclbot <clbot@tvl.fyi>2024-05-13T16·57+0000
commitafcbc1d86d272527aa338f1fa8c998f54a39401a (patch)
tree150f92f6c4e6aa7959fbc13f27d68ceb026abe19 /tvix/build/Cargo.toml
parent14353ce7510748b8fd7daa2298ac48528c9a0c75 (diff)
chore(tvix/clippy): configure clippy allow block_in_conditions r/8139
… in Cargo.toml.

This gets an imperative `cargo clippy` run to pick up that config,
so `-A clippy::blocks_in_conditions` doesn't need to be explicitly
specified anymore.

Change-Id: I32b6cc50c77c22cba0d816d0db508c2f94b2c383
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11659
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: edef <edef@edef.eu>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 626fd35d77..dc676b1813 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -31,3 +31,6 @@ tonic-reflection = ["dep:tonic-reflection"]
 
 [dev-dependencies]
 rstest = "0.19.0"
+
+[lints]
+workspace = true