about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-15T16·43+0200
committerclbot <clbot@tvl.fyi>2024-01-15T18·25+0000
commit4fb4fc263d31e207f0fc842f17e98ca276094e00 (patch)
tree08941afd4ff3c8d62768980f94a80a9a1b019ab8 /tvix/build/Cargo.toml
parent9fd15ba506c86cd4c1d84aa43d5f3767e02761db (diff)
feat(tvix/build): add BuildService trait r/7383
Also provide a dummy implementation that just fails on any build that's
requested.

Change-Id: I0df743a730c5331ec9ce6e97a966abe18ce067f5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10627
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 7b1594abc3..2782128db3 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -10,6 +10,7 @@ prost = "0.12.1"
 thiserror = "1.0.56"
 tonic = "0.10.2"
 tvix-castore = { path = "../castore" }
+tracing = "0.1.37"
 
 [dependencies.tonic-reflection]
 optional = true