about summary refs log tree commit diff
path: root/tvix/boot/tests/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-07-20T23·36+0200
committerflokli <flokli@flokli.de>2024-07-21T00·06+0000
commitfdc0cf0c94827fc4940c9f8ac4d310d57aec9f35 (patch)
treea9d601d024d5db5dced9f21b6073b7245d8c6f99 /tvix/boot/tests/default.nix
parentd136f2c8817ee72ff673f65d7f882d5918ed366a (diff)
refactor(tvix/boot/tests): use nar-bridge-rs r/8383
This switches the boot tests from the golang implementation to the rust
one.

Change-Id: Ide2a47aebe40c172077147c05bb6dacd74ba6b1e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11997
Tested-by: BuildkiteCI
Reviewed-by: Brian Olsen <me@griff.name>
Diffstat (limited to 'tvix/boot/tests/default.nix')
-rw-r--r--tvix/boot/tests/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tvix/boot/tests/default.nix b/tvix/boot/tests/default.nix
index 26640d6e921b..a6c3047d08f5 100644
--- a/tvix/boot/tests/default.nix
+++ b/tvix/boot/tests/default.nix
@@ -45,7 +45,7 @@ let
           depot.tvix.store
           depot.tvix.boot.runVM
         ] ++ lib.optionals (isClosure && useNarBridge) [
-          depot.tvix.nar-bridge-go
+          depot.tvix.nar-bridge
           pkgs.curl
           pkgs.parallel
           pkgs.xz.bin
@@ -85,10 +85,9 @@ let
           tvix-store --otlp=false copy
         '' + lib.optionalString (isClosure && useNarBridge) ''
           echo "Starting nar-bridge…"
-          nar-bridge-http \
+          nar-bridge \
             --otlp=false \
-            --store-addr=unix://$PWD/tvix-store.sock \
-            --listen-addr=$PWD/nar-bridge.sock &
+            -l $PWD/nar-bridge.sock &
 
           # Wait for the socket to be created.
           while [ ! -e $PWD/nar-bridge.sock ]; do sleep 1; done