about summary refs log tree commit diff
path: root/tvix/boot/tests/default.nix
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-19T13·08+0300
committerclbot <clbot@tvl.fyi>2024-08-19T16·55+0000
commitbc967c538d61c2dbf7a321c95062a215484fa946 (patch)
treee6b610bb9c8c450cff5237f6d022a161ad2cd6de /tvix/boot/tests/default.nix
parent70d199ea44ce2b8a4982cde920c691f779c17e2f (diff)
feat(tvix/boot/tests): use pkgs.nixos instead of nixosFor r/8537
Using pkgs.nixos directly allows us to create a smaller nixos closure
for the tests and also not depend on things in depot.ops which can be
beneficial for extending the tvix josh workspace.

Change-Id: Ic6ad2122733418114b43aa692d6e42ac1e308eeb
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12251
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Diffstat (limited to 'tvix/boot/tests/default.nix')
-rw-r--r--tvix/boot/tests/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/tvix/boot/tests/default.nix b/tvix/boot/tests/default.nix
index d078287a7b9b..97477572078e 100644
--- a/tvix/boot/tests/default.nix
+++ b/tvix/boot/tests/default.nix
@@ -132,9 +132,7 @@ let
         exportReferencesGraph.closure = [ path ];
       });
 
-  systemFor = sys: (depot.ops.nixos.nixosFor sys).system;
-
-  testSystem = systemFor ({ modulesPath, pkgs, ... }: {
+  testSystem = (pkgs.nixos {
     # Set some options necessary to evaluate.
     boot.loader.systemd-boot.enable = true;
     # TODO: figure out how to disable this without causing eval to fail
@@ -154,7 +152,10 @@ let
 
     # Don't warn about stateVersion.
     system.stateVersion = "24.05";
-  });
+
+    # Speed-up evaluation and building.
+    documentation.enable = lib.mkForce false;
+  }).config.system.build.toplevel;
 
 in
 depot.nix.readTree.drvTargets