about summary refs log tree commit diff
path: root/tvix/boot/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-07-01T06·37+0300
committerflokli <flokli@flokli.de>2024-07-01T07·24+0000
commit87f38cad6140a10f436ba4d60b52735cc545bc63 (patch)
tree749e04a915898505f41d39c5e30b3182ff612c28 /tvix/boot/default.nix
parentafbe995aa94e308c14b8881d3057e8177f44c2e5 (diff)
fix(tvix/boot): use shrunk kernel image r/8332
The aarch64-linux version of this is too big for cloud-hypervisor to
accept.

The correct place for this is in
`${kernel}/${stdenv.hostPlatform.linux-kernel.target}`, the other output
is only useful for debugging purposes.

This gets cloud-hypervisor to start booting up the kernel. It still
doesn't boot successfully, but it's getting further.

Part of b/407.

Change-Id: I3fbe52597fb1a6f5728a7f375dd35b50e00b3b1a
Co-Authored-By: Alyssa Ross <hi@alyssa.is>
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11905
Tested-by: BuildkiteCI
Reviewed-by: Alyssa Ross <hi@alyssa.is>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to '')
-rw-r--r--tvix/boot/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/boot/default.nix b/tvix/boot/default.nix
index 85995ffbf2..7be05c815c 100644
--- a/tvix/boot/default.nix
+++ b/tvix/boot/default.nix
@@ -99,7 +99,7 @@ rec {
      --memory mergeable=on,shared=on,size=$CH_MEM_SIZE \
      --console null \
      --serial tty \
-     --kernel ${kernel.dev}/vmlinux \
+     --kernel ${kernel}/${pkgs.stdenv.hostPlatform.linux-kernel.target} \
      --initramfs ${initrd} \
      --cmdline "console=ttyS0 $CH_CMDLINE" \
      --fs tag=tvix,socket=$tempdir/tvix.sock,num_queues=''${CH_NUM_CPU},queue_size=512