about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-12-30T22·24+0100
committerclbot <clbot@tvl.fyi>2022-01-06T19·35+0000
commit80defc2101e7b99a2f379230833676d8feda0343 (patch)
treedd6d982fc720f78c9dba580ff5ed2690f6873531 /tvix/Cargo.toml
parent7c92b07efd6d3a183c2b6970102647fea08fc49a (diff)
feat(tvix): set up a simple command line parser for nix-store r/3522
We are going to have a 1:1 drop-in replacement for the old-style nix
tools, and this starts implementing the cli parser part.

The first step is to have a simple integration test suite that can
verify that we match the nix CLI.

clap is a super complicated parsing library, but looking through the
rest they are either too opinioated to be of use for us, or depend on
clap as implementation.

Change-Id: I4cf6051f3a4f782c3242fd0d2b9eab3fbe33d8ad
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4756
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index 2a59a77eaf..8b0fbd846a 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -5,6 +5,10 @@ edition = "2021"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
+[dependencies.clap]
+version = "3.0.5"
+[dependencies.tempfile]
+version = "3.2.0"
 
 [[bin]]
 name = "nix-store"