about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-24T20·56+0200
committerclbot <clbot@tvl.fyi>2023-12-24T21·45+0000
commitacbb613e6147205ffadcf163afaf9076b4fbbb39 (patch)
tree18af47b4309699caabf881f947bca6e1e051fa4e /tvix/Cargo.toml
parent1f76c5b8639b41b986328d2ddfd0b5c886b3a5ae (diff)
chore(tvix): switch to upstream futures 0.3.30 r/7261
The bugs have been fixed,
https://github.com/rust-lang/futures-rs/pull/2801 and
https://github.com/rust-lang/futures-rs/pull/2812 were merged and ended
up in that release.

Change-Id: Iefd990d2d1719b884504093343e54e9c5258e2e2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10414
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml12
1 files changed, 0 insertions, 12 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index aa4f26b1c1..6cd19831dc 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -36,15 +36,3 @@ members = [
 [profile.release-with-debug]
 inherits = "release"
 debug = true
-
-[patch.crates-io]
-# https://github.com/rust-lang/futures-rs/pull/2801
-# replace once https://github.com/rust-lang/futures-rs/pull/2812 has been backported and released.
-futures-channel = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-core = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-executor = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-io = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-macro = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-sink = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-task = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
-futures-util = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }