about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-16T21·32+0200
committerclbot <clbot@tvl.fyi>2023-12-16T21·47+0000
commit7749814953703cc31c726d47ddf24bd32f1982c7 (patch)
tree8bbba78c8044bbbd7856dec33caceda48633ff83 /tvix/Cargo.toml
parent43ab1543e22f12eb6cf3b290f8ec2c04818041e4 (diff)
docs(tvix): refer to futures-rs PR r/7225
The PR has since been replaced with another version, using a bit of
unsafe, as rustc doesn't like the lifetimes.
We're still waiting on a backport of that to 0.3.

Change-Id: I8dd344e78162cd956f6e53ff05dc4c02763fbb04
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10376
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index 44f5a69874..aa4f26b1c1 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -39,6 +39,7 @@ debug = true
 
 [patch.crates-io]
 # https://github.com/rust-lang/futures-rs/pull/2801
+# replace once https://github.com/rust-lang/futures-rs/pull/2812 has been backported and released.
 futures-channel = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
 futures-core = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
 futures-executor = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }