about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorsinavir <tvix@sinavir.fr>2024-07-22T13·09+0200
committerclbot <clbot@tvl.fyi>2024-09-26T12·29+0000
commit9f36632509078d65d1229828237f64e876ffd48f (patch)
treec06753deaef09fde92c8fdfbcc5203eab9cdcfe4 /tvix/Cargo.nix
parente4378f01433cc52300ac68d79406e0d5e6a05d50 (diff)
feat(tvix/store): Add a signing PathInfoService r/8716
- Add a new PathInfoService implementation that wraps transparently
around another except that it dynamically signs all the incoming
path-infos with the provided signer.

- Add a ServiceBuilder for this PathInfoService that provides a
SigningPathInfoService with a keyfile signer

Change-Id: I845ddfdf01d14c503c796b2b80c720dab98be091
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12032
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: sinavir <tvix@sinavir.fr>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 2cc3aa64da37..77719d745ad7 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -15573,6 +15573,14 @@ rec {
             packageId = "data-encoding";
           }
           {
+            name = "ed25519";
+            packageId = "ed25519";
+          }
+          {
+            name = "ed25519-dalek";
+            packageId = "ed25519-dalek";
+          }
+          {
             name = "futures";
             packageId = "futures";
           }