about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-10-13T15·02+0300
committerclbot <clbot@tvl.fyi>2024-10-13T16·23+0000
commit15b5bf2003df5fd4a62e47c7ca1f4efbbb5d87cc (patch)
tree1963bc23b2b271629afed13f8e9455f51acf2ba4 /tvix/Cargo.nix
parent4beee4cba79efda4145e84c12ecbc876f39f2134 (diff)
refactor(tvix/build): remove use of lazy_static r/8804
This is now supported in the standard library via std::sync::LazyLock,
but requires some manual shuffling around of code.

Change-Id: Ie2af74beda9fcf8aa19fca7d844bcbe732f05bf8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12610
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index ed955fa56dd6..8cedc2de7fd6 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -15098,10 +15098,6 @@ rec {
         ];
         devDependencies = [
           {
-            name = "lazy_static";
-            packageId = "lazy_static";
-          }
-          {
             name = "rstest";
             packageId = "rstest";
           }