about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2024-10-12T22·30+0300
committerclbot <clbot@tvl.fyi>2024-10-12T23·02+0000
commitb21cb11b7f65d84baca62a0492d63d184e4f5095 (patch)
treef54370e33f25e71449dd3daf4c5ffc6edbeec4b4 /tvix/Cargo.nix
parentb7a6fc2812f3ed281ba1a0b985a2ae150095f7b1 (diff)
refactor(tvix/eval): remove usage of lazy_static r/8797
Equivalent logic is now in the standard library, and this dependency is no
longer needed for eval.

Change-Id: Iaa4410d89fdaa5b84cbd9e6bc6ae479c659d92f2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12602
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: edef <edef@edef.eu>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 24f97de7dc21..deeb10171f29 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -15556,10 +15556,6 @@ rec {
             packageId = "itertools 0.12.1";
           }
           {
-            name = "lazy_static";
-            packageId = "lazy_static";
-          }
-          {
             name = "lexical-core";
             packageId = "lexical-core";
             features = [ "format" "parse-floats" ];