about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-09-27T14·56+0200
committerclbot <clbot@tvl.fyi>2024-09-27T20·39+0000
commitcaf597db8107d7cb8c4772e83552e9774f85c5c5 (patch)
treeec166388b2d8ddef9b1d42656c4dd14f5f06d501 /tvix/Cargo.nix
parented2bd8885052494bcf208f97e292d746f223a117 (diff)
refactor(tvix): move refscan module to castore r/8724
This is required to add the optional refscanner parameter to the
ingest functions.

Change-Id: Ib40a7287cf857eb55e31e0df309a79474fefb518
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12527
Autosubmit: yuka <yuka@yuka.dev>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix20
1 files changed, 12 insertions, 8 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 77719d745ad7..84003aeeacc9 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -14815,6 +14815,10 @@ rec {
             packageId = "petgraph";
           }
           {
+            name = "pin-project";
+            packageId = "pin-project";
+          }
+          {
             name = "pin-project-lite";
             packageId = "pin-project-lite";
           }
@@ -14940,6 +14944,10 @@ rec {
             packageId = "walkdir";
           }
           {
+            name = "wu-manber";
+            packageId = "wu-manber";
+          }
+          {
             name = "zstd";
             packageId = "zstd";
           }
@@ -14984,6 +14992,10 @@ rec {
             packageId = "tokio-retry";
           }
           {
+            name = "tokio-test";
+            packageId = "tokio-test";
+          }
+          {
             name = "xattr";
             packageId = "xattr";
           }
@@ -15440,10 +15452,6 @@ rec {
             name = "walkdir";
             packageId = "walkdir";
           }
-          {
-            name = "wu-manber";
-            packageId = "wu-manber";
-          }
         ];
         devDependencies = [
           {
@@ -15480,10 +15488,6 @@ rec {
             name = "tempfile";
             packageId = "tempfile";
           }
-          {
-            name = "tokio-test";
-            packageId = "tokio-test";
-          }
         ];
         features = {
           "default" = [ "nix_tests" ];