about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-06-12T21·17+0300
committerclbot <clbot@tvl.fyi>2024-06-12T23·43+0000
commitddd88a589b3a4610627ba5620e273f4d055541f0 (patch)
treef7fe710d6a98e3dc437c1c8517eaaedb994559ae /tvix/Cargo.nix
parent842d6816bfa5a8f393719e4cb1e8bfc4d8c14174 (diff)
feat(tvix/glue/tvix_store_io): show progress info r/8255
In `store_path_to_node`, in case we need to build or fetch something,
render a progress bar, using the spinner for now.
We can upgrade this to a progress *bar* later.

Change-Id: I4a7cf5ef8f639076f176af9b39d276be3f37c8ff
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11793
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index da67d34c311d..6200fe6025b9 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -13642,6 +13642,10 @@ rec {
             packageId = "tracing";
           }
           {
+            name = "tracing-indicatif";
+            packageId = "tracing-indicatif";
+          }
+          {
             name = "tvix-build";
             packageId = "tvix-build";
             usesDefaultFeatures = false;
@@ -13660,6 +13664,10 @@ rec {
             usesDefaultFeatures = false;
           }
           {
+            name = "tvix-tracing";
+            packageId = "tvix-tracing";
+          }
+          {
             name = "url";
             packageId = "url";
           }