about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-08-29T15·11+0300
committerclbot <clbot@tvl.fyi>2024-08-30T13·55+0000
commit9803712ab8db5e71354ee192776c00f85b9b0ffb (patch)
tree420b3817ed2a890617629a4edbc11163807e58c1 /tvix/Cargo.nix
parent55b0726571fa5481dc604bb28cdc204fada495a3 (diff)
fix(tvix): Follow-up fixing no-default-features and comments r/8619
In https://cl.tvl.fyi/c/depot/+/12389 I accidentally deleted some
comments. Also fixed some useless no-default-features with futures crate, making it match the previous feature combination.

Change-Id: I72bb2cfb88719ff2f8812d90193de2bd49149cce
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12395
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix6
1 files changed, 0 insertions, 6 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 4cb07f1a13e0..5671624ceceb 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -6627,7 +6627,6 @@ rec {
           {
             name = "futures";
             packageId = "futures";
-            usesDefaultFeatures = false;
           }
           {
             name = "itertools";
@@ -7043,8 +7042,6 @@ rec {
           {
             name = "futures";
             packageId = "futures";
-            usesDefaultFeatures = false;
-            features = [ "executor" ];
           }
           {
             name = "hex-literal";
@@ -14790,7 +14787,6 @@ rec {
           {
             name = "futures";
             packageId = "futures";
-            usesDefaultFeatures = false;
           }
           {
             name = "hyper-util";
@@ -15346,7 +15342,6 @@ rec {
           {
             name = "futures";
             packageId = "futures";
-            usesDefaultFeatures = false;
           }
           {
             name = "magic";
@@ -15576,7 +15571,6 @@ rec {
           {
             name = "futures";
             packageId = "futures";
-            usesDefaultFeatures = false;
           }
           {
             name = "hyper-util";