about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-07-22T13·41+0200
committerclbot <clbot@tvl.fyi>2024-07-22T15·57+0000
commit2547ff2cf6c6e8fefa6f55e3583bea1b1d8f4263 (patch)
treedfba0f40f8bdc91136b9dd9840b6872d9dca2219 /tvix/Cargo.nix
parent39c8b6dece1ca414f4ce8dde49e9828e34319664 (diff)
feat(tvix/store): add grpc healthcheck service to daemon r/8403
Change-Id: Ib95fc9352a45d54f9a16c8841c7e8f7cbeeaee8c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12019
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: yuka <yuka@yuka.dev>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 12d111bed17f..64d0adabfdd4 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -14489,6 +14489,54 @@ rec {
         };
         resolvedDefaultFeatures = [ "default" "prost" "prost-build" "transport" ];
       };
+      "tonic-health" = rec {
+        crateName = "tonic-health";
+        version = "0.12.1";
+        edition = "2021";
+        sha256 = "0ma93g27szqjh4gniws6wz82ils2hhvd91rl8k7bc27fjrm0xqg1";
+        authors = [
+          "James Nugent <james@jen20.com>"
+        ];
+        dependencies = [
+          {
+            name = "async-stream";
+            packageId = "async-stream";
+          }
+          {
+            name = "prost";
+            packageId = "prost 0.13.1";
+          }
+          {
+            name = "tokio";
+            packageId = "tokio";
+            features = [ "sync" ];
+          }
+          {
+            name = "tokio-stream";
+            packageId = "tokio-stream";
+          }
+          {
+            name = "tonic";
+            packageId = "tonic 0.12.1";
+            usesDefaultFeatures = false;
+            features = [ "codegen" "prost" ];
+          }
+        ];
+        devDependencies = [
+          {
+            name = "tokio";
+            packageId = "tokio";
+            features = [ "rt-multi-thread" "macros" ];
+          }
+          {
+            name = "tokio-stream";
+            packageId = "tokio-stream";
+          }
+        ];
+        features = {
+          "default" = [ "transport" ];
+        };
+      };
       "tonic-reflection" = rec {
         crateName = "tonic-reflection";
         version = "0.12.1";
@@ -16428,6 +16476,11 @@ rec {
             features = [ "tls" "tls-roots" ];
           }
           {
+            name = "tonic-health";
+            packageId = "tonic-health";
+            usesDefaultFeatures = false;
+          }
+          {
             name = "tonic-reflection";
             packageId = "tonic-reflection";
             optional = true;