about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorBrian Olsen <brian@maven-group.org>2024-08-28T13·45+0200
committerclbot <clbot@tvl.fyi>2024-08-28T14·43+0000
commita5fcfd80a16d985bcef7011ad94eab86cc0b4a72 (patch)
tree00d6f3fcea7d4da814eb31dce1bc3a2cef7850dc /tvix/Cargo.nix
parent743407e7abf9cf56274c8c9bcb1edb10d8f943ed (diff)
fix(tvix/nix-compat-derive): Get rid of external feature flag r/8602
The external feature flag was there because I couldn't find a way to
refer to crate and nix-compat with the same name so that the generated
code could be the same.

In essence `use nix_compat::nix_daemon::de::NixDeserialize` is an error
when used inside nix_compat crate.

So my best fix was the external feature flag until I found the solution
used here which also removes the flag completely.

Change-Id: Ia3e89c6c350c3fb22ca87f974a39c21542aae152
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12376
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: Brian Olsen <me@griff.name>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index c9fec85e2e37..be49a5c019b6 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -7419,7 +7419,6 @@ rec {
             name = "nix-compat-derive";
             packageId = "nix-compat-derive";
             optional = true;
-            usesDefaultFeatures = false;
           }
           {
             name = "nom";
@@ -7575,10 +7574,7 @@ rec {
             packageId = "tokio-test";
           }
         ];
-        features = {
-          "default" = [ "external" ];
-        };
-        resolvedDefaultFeatures = [ "default" "external" ];
+
       };
       "nix-compat-derive-tests" = rec {
         crateName = "nix-compat-derive-tests";