about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-06-14T11·17+0300
committerflokli <flokli@flokli.de>2024-06-15T05·24+0000
commit01aadace80108e32322ea64a7ca355a1cb04d3d9 (patch)
tree9ae4c37816c5db8842b3e80a030ce607b3cacca8 /tvix/Cargo.nix
parentcd0b92419a8c27fe6556cc3fc6acaf3fed7a50d6 (diff)
feat(tvix/cli,store): add tracy feature r/8280
If compiled with this features, this emits packets compatible with the
[Tracy](https://github.com/wolfpld/tracy) format.

Change-Id: I330f5d85ab290abe51f2df38dc55464f3ccfc6cd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11815
Tested-by: BuildkiteCI
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index f854a7cf0ea2..3b8c45bf48f4 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -13546,7 +13546,10 @@ rec {
             packageId = "wu-manber";
           }
         ];
-
+        features = {
+          "tracy" = [ "tvix-tracing/tracy" ];
+        };
+        resolvedDefaultFeatures = [ "default" "tracy" ];
       };
       "tvix-eval" = rec {
         crateName = "tvix-eval";
@@ -14175,9 +14178,10 @@ rec {
           "fuse" = [ "tvix-castore/fuse" ];
           "otlp" = [ "tvix-tracing/otlp" ];
           "tonic-reflection" = [ "dep:tonic-reflection" "tvix-castore/tonic-reflection" ];
+          "tracy" = [ "tvix-tracing/tracy" ];
           "virtiofs" = [ "tvix-castore/virtiofs" ];
         };
-        resolvedDefaultFeatures = [ "cloud" "default" "fuse" "integration" "otlp" "tonic-reflection" "virtiofs" ];
+        resolvedDefaultFeatures = [ "cloud" "default" "fuse" "integration" "otlp" "tonic-reflection" "tracy" "virtiofs" ];
       };
       "tvix-tracing" = rec {
         crateName = "tvix-tracing";