about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-05-26T16·19+0200
committerclbot <clbot@tvl.fyi>2024-05-26T19·46+0000
commitca542440a5ac6d48f962a26febffcfc17514ad5d (patch)
tree5c29e17879214196ae835173466c949a2cd5a8b3 /tvix/Cargo.nix
parent9586e5c30da23dd25d404d075a64161689f8cc02 (diff)
fix(tvix/build): tonic-reflection feature needs castore with it too r/8173
If building tvix-build with the tonic-reflection feature, it needs
to import `tvix_castore::proto::FILE_DESCRIPTOR_SET`, which is only
available if tvix-castore is built with the `tonic-reflection` feature.

Change-Id: I355b4c5b4c1333d5cc56335de47ad5d2f1db6337
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11716
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 0bae0a6f20fa..f56618114031 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -12760,7 +12760,7 @@ rec {
           }
         ];
         features = {
-          "tonic-reflection" = [ "dep:tonic-reflection" ];
+          "tonic-reflection" = [ "dep:tonic-reflection" "tvix-castore/tonic-reflection" ];
         };
         resolvedDefaultFeatures = [ "default" "tonic-reflection" ];
       };