about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorYureka <tvl@yuka.dev>2024-05-16T08·33+0200
committerclbot <clbot@tvl.fyi>2024-05-16T16·33+0000
commit6aa1d2c4a8bd7b72e6f8be243d2aa8581556cd4a (patch)
tree03b765f5c79c1bfdaadaa2ce9854845d9646de98 /tvix/Cargo.nix
parentb080870fd99817c194b5e72c96a187739495d06a (diff)
feat(tvix/store): add ObjectStoreDirectoryService r/8150
Change-Id: I1636012be2e8ee3ae64f7bc62fd28bfe0cb2bca5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11668
Autosubmit: yuka <yuka@yuka.dev>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 2303f4b946ea..088bd6fdfcbf 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -12816,6 +12816,11 @@ rec {
           else ./castore;
         dependencies = [
           {
+            name = "async-compression";
+            packageId = "async-compression";
+            features = [ "tokio" "zstd" ];
+          }
+          {
             name = "async-stream";
             packageId = "async-stream";
           }
@@ -12931,7 +12936,7 @@ rec {
           {
             name = "tokio-util";
             packageId = "tokio-util";
-            features = [ "io" "io-util" ];
+            features = [ "io" "io-util" "codec" ];
           }
           {
             name = "tonic";