about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-05-11T15·01+0300
committerflokli <flokli@flokli.de>2023-05-24T09·25+0000
commit5774117d5ea4115a33923640a39a553eb57df59a (patch)
tree2e77cdb73837f688a7bc268366d6846ef5a503f9 /tvix/Cargo.nix
parent4b00f1d7ac855e90e15633a2e2ba3a90c3921fac (diff)
feat(tvix/store): implement TvixStoreIO r/6191
This providesEvalIO, asking given PathInfoService, DirectoryService
and BlobService.

Change-Id: I32f210f5a7aa8173ad9a7d53e8a5ac03619f527a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8561
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index cf571a36b0..f7cc72d6f8 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -8033,6 +8033,10 @@ rec {
             packageId = "rayon";
           }
           {
+            name = "serde_json";
+            packageId = "serde_json";
+          }
+          {
             name = "sha2";
             packageId = "sha2 0.10.6";
           }
@@ -8042,6 +8046,10 @@ rec {
             features = [ "compression" ];
           }
           {
+            name = "smol_str";
+            packageId = "smol_str";
+          }
+          {
             name = "thiserror";
             packageId = "thiserror";
           }
@@ -8082,6 +8090,10 @@ rec {
             features = [ "json" ];
           }
           {
+            name = "tvix-eval";
+            packageId = "tvix-eval";
+          }
+          {
             name = "walkdir";
             packageId = "walkdir";
           }