about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-03-11T20·21+0100
committerflokli <flokli@flokli.de>2023-03-13T10·05+0000
commitc8bbddd5e55412c1b1319677e457d8175d6e78ab (patch)
tree0abf64e227ddb1d52ea6d6624e7dce5abd5f0b89 /tvix/Cargo.nix
parent7ffb2676ee6d96f382d138d638b4e2a6a3f6841d (diff)
refactor(tvix/store): use read_all_and_chunk in gRPC blobservice r/5959
This was the last piece of code using BlobWriter.

We can also use `read_all_and_chunk`, it's just requires a bit more
plumbing:

 - The data coming from the client (stream) needs to be mapped (we
   extract the .data field).
 - The stream needs to be turned into an (async) reader
 - The reader needs to be made sync, and that code using the sync reader
   needs to be in a `task::spawn_blocking`.

Change-Id: I4e374e1a9f47d5a0933f59a8f5c121185a5f3e95
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8260
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 2d130f42c8..363db976dd 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -7004,9 +7004,9 @@ rec {
       };
       "tokio-util" = rec {
         crateName = "tokio-util";
-        version = "0.7.4";
+        version = "0.7.7";
         edition = "2018";
-        sha256 = "0h67jb56bsxy4pi1a41pda8d52569ci5clvqv3c6cg9vy1sy1chb";
+        sha256 = "1cp6yx4789j6gvbp4xnbk7lpd7q0j2a2qd4g1pg2b4q0afadh9sl";
         authors = [
           "Tokio Contributors <team@tokio.rs>"
         ];
@@ -7062,7 +7062,7 @@ rec {
           "time" = [ "tokio/time" "slab" ];
           "tracing" = [ "dep:tracing" ];
         };
-        resolvedDefaultFeatures = [ "codec" "default" "tracing" ];
+        resolvedDefaultFeatures = [ "codec" "default" "io" "io-util" "tracing" ];
       };
       "toml" = rec {
         crateName = "toml";
@@ -8357,6 +8357,11 @@ rec {
             packageId = "tokio-stream";
           }
           {
+            name = "tokio-util";
+            packageId = "tokio-util";
+            features = [ "io" "io-util" ];
+          }
+          {
             name = "tonic";
             packageId = "tonic";
           }