about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-12-29T11·07+0100
committerflokli <flokli@flokli.de>2022-12-29T12·07+0000
commitb0879917d4f4adbe4dac6bdf7f75d9e19f559114 (patch)
tree7adcba087da71f2ee84c0a82f5651e219852f9ae /tvix/Cargo.nix
parentff71366f41daa0da09c1e4304ed05cdc908612cb (diff)
chore(tvix/store): trim Cargo.toml r/5532
lazy_static is only used in tests, and anyhow isn't used at all (yet).

This can be dropped.

Change-Id: Ic41ff3f9bb93cfa600c3485e85464f78a3976504
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7668
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 8e55db79c4..aa9fc5d9dc 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -6172,10 +6172,6 @@ rec {
             features = [ "rayon" "std" ];
           }
           {
-            name = "lazy_static";
-            packageId = "lazy_static";
-          }
-          {
             name = "prost";
             packageId = "prost";
           }
@@ -6198,6 +6194,12 @@ rec {
             packageId = "tonic-build";
           }
         ];
+        devDependencies = [
+          {
+            name = "lazy_static";
+            packageId = "lazy_static";
+          }
+        ];
 
       };
       "typenum" = rec {