about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-15T17·22+0200
committerclbot <clbot@tvl.fyi>2024-01-15T18·54+0000
commitf0a750bcb7e3145974f99383a5db905b9e0d72a3 (patch)
treeccb416ea9c9134bf2b118f68fc6ce0b74c6962fb /tvix/Cargo.nix
parent170e0cdfadd96176595c47b573d0a1f27a7c734b (diff)
feat(tvix/build): add CLI entrypoint r/7387
This starts a BuildService as a separate process, currently defaulting
to the DummyBuildService.

Change-Id: Ic206f00831641d3ffebaa44883b7dc053700b9ca
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10631
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index d1ffbf3264..e3f4be07e3 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -10214,6 +10214,13 @@ rec {
         crateName = "tvix-build";
         version = "0.1.0";
         edition = "2021";
+        crateBin = [
+          {
+            name = "tvix-build";
+            path = "src/bin/tvix-build.rs";
+            requiredFeatures = [ ];
+          }
+        ];
         # We can't filter paths with references in Nix 2.4
         # See https://github.com/NixOS/nix/issues/5410
         src =
@@ -10226,6 +10233,11 @@ rec {
             packageId = "bytes";
           }
           {
+            name = "clap";
+            packageId = "clap";
+            features = [ "derive" "env" ];
+          }
+          {
             name = "itertools";
             packageId = "itertools 0.12.0";
           }
@@ -10242,6 +10254,11 @@ rec {
             packageId = "tokio";
           }
           {
+            name = "tokio-listener";
+            packageId = "tokio-listener";
+            features = [ "tonic010" ];
+          }
+          {
             name = "tonic";
             packageId = "tonic 0.10.2";
             features = [ "tls" "tls-roots" ];
@@ -10256,6 +10273,11 @@ rec {
             packageId = "tracing";
           }
           {
+            name = "tracing-subscriber";
+            packageId = "tracing-subscriber";
+            features = [ "json" ];
+          }
+          {
             name = "tvix-castore";
             packageId = "tvix-castore";
           }