about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-02T12·17+0200
committerclbot <clbot@tvl.fyi>2024-01-03T14·15+0000
commit802f374a90d8202785a34648c39aa6320ac171d9 (patch)
tree95ddd57c989bcc8f44771384793d8dad37910e91 /tvix/Cargo.nix
parenta82214b3ad00a402db222fa2df276a30c0a86c47 (diff)
feat(tvix/glue): handle passAsFile r/7316
This extends derivation_to_build_request to handle passAsFile the same
way Nix does, and adds a unit test for it.

I opted to making this function fallible (if passAsFile contains a
non-existent env var), rather than pushing all of this into the
Derivation validate function.

Change-Id: I75b635f1f6c0c78d72b9a8fc7824f77e97b69951
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10522
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 69b9cc9a8d..1ad3422d30 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -1971,9 +1971,9 @@ rec {
       };
       "digest" = rec {
         crateName = "digest";
-        version = "0.10.6";
+        version = "0.10.7";
         edition = "2018";
-        sha256 = "0vz74785s96g727vg37iwkjvbkcfzp093j49ihhyf8sh9s7kfs41";
+        sha256 = "14p2n6ih29x81akj097lvz7wi9b6b9hvls0lwrv7b6xwyy0s5ncy";
         authors = [
           "RustCrypto Developers"
         ];
@@ -7873,9 +7873,9 @@ rec {
       };
       "sha2" = rec {
         crateName = "sha2";
-        version = "0.10.6";
+        version = "0.10.8";
         edition = "2018";
-        sha256 = "1h5xrrv2y06kr1gsz4pwrm3lsp206nm2gjxgbf21wfrfzsavgrl2";
+        sha256 = "1j1x78zk9il95w9iv46dh9wm73r6xrgj32y6lzzw7bxws9dbfgbr";
         authors = [
           "RustCrypto Developers"
         ];
@@ -10728,6 +10728,10 @@ rec {
             packageId = "nix-compat";
           }
           {
+            name = "sha2";
+            packageId = "sha2";
+          }
+          {
             name = "thiserror";
             packageId = "thiserror";
           }