about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-12-20T16·23+0300
committertazjin <tazjin@tvl.su>2022-12-21T14·08+0000
commita95dea719f1b44231c485e52816c5fff4cfe42dd (patch)
treec4193fe7325f9f660c532866c1817cea22cda11f /tvix/Cargo.nix
parentf467df06dcfa8383c3bd36e7877b8cf900e973c9 (diff)
chore(tvix/nar): add CI build target r/5450
Change-Id: Ic73a391da9a733cade26114ab1127907c8d62a57
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7598
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 886a39e428..084133c186 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -73,6 +73,16 @@ rec {
       # File a bug if you depend on any for non-debug work!
       debug = internal.debugCrate { inherit packageId; };
     };
+    "tvix-nar" = rec {
+      packageId = "tvix-nar";
+      build = internal.buildRustCrateWithFeatures {
+        packageId = "tvix-nar";
+      };
+
+      # Debug support which might change between releases.
+      # File a bug if you depend on any for non-debug work!
+      debug = internal.debugCrate { inherit packageId; };
+    };
     "tvix-store" = rec {
       packageId = "tvix-store";
       build = internal.buildRustCrateWithFeatures {
@@ -4374,6 +4384,18 @@ rec {
         ];
 
       };
+      "tvix-nar" = rec {
+        crateName = "tvix-nar";
+        version = "0.0.0";
+        edition = "2021";
+        # We can't filter paths with references in Nix 2.4
+        # See https://github.com/NixOS/nix/issues/5410
+        src =
+          if (lib.versionOlder builtins.nixVersion "2.4pre20211007")
+          then lib.cleanSourceWith { filter = sourceFilter; src = ./nar; }
+          else ./nar;
+
+      };
       "tvix-store" = rec {
         crateName = "tvix-store";
         version = "0.1.0";