about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-01-15T17·15+0200
committerclbot <clbot@tvl.fyi>2024-01-15T18·49+0000
commit170e0cdfadd96176595c47b573d0a1f27a7c734b (patch)
tree1a2a591b1f162062096aecc3f124f25f433e34c4 /tvix/Cargo.nix
parent5aa9b29d8cdf870ee6f3ad01a874604ff9f93e45 (diff)
feat(tvix/build): add from_addr method r/7386
This allows constructing a BuildService from a URI, similar to how it's
done in tvix-[ca]store.

Change-Id: Ib962b329535c6c7e378ab7ac7f4dd254366497b3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10630
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 71f456290d..d1ffbf3264 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -10238,6 +10238,10 @@ rec {
             packageId = "thiserror";
           }
           {
+            name = "tokio";
+            packageId = "tokio";
+          }
+          {
             name = "tonic";
             packageId = "tonic 0.10.2";
             features = [ "tls" "tls-roots" ];
@@ -10255,6 +10259,10 @@ rec {
             name = "tvix-castore";
             packageId = "tvix-castore";
           }
+          {
+            name = "url";
+            packageId = "url";
+          }
         ];
         buildDependencies = [
           {