about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-12-09T11·14+0200
committerclbot <clbot@tvl.fyi>2023-12-09T12·58+0000
commitf11c6d610ce002774df714cf2c998989643dccfa (patch)
tree6afb85e6b90bdbf74dbecbd037bc4d8d631081ca /tvix/Cargo.nix
parent0907420600ba0f9270065dd83e81fb8f56dfda71 (diff)
chore(tvix/nix_cli): drop crate r/7133
The only thing this was doing was invoking nix-store --add, which is not
gonna help us populate the tvix-store at all (and we now have
`tvix-store import`).

This is also (rightfully) causing clippy warnings, because of some
fields being unused.

It's more of a skeleton, and rather than shelling out to Nix for some
usecases, we might introduce a "compatible" Nix CLI frontend for a
subset of commands.

Drop this for now, to decrease the noise and confusion.

Change-Id: I2fd399e9320260f08893b685561755af9c7c961c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10226
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 6270f89761..b6d17d2165 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -33,16 +33,6 @@ rec {
   # You can override the features with
   # workspaceMembers."${crateName}".build.override { features = [ "default" "feature1" ... ]; }.
   workspaceMembers = {
-    "nix-cli" = rec {
-      packageId = "nix-cli";
-      build = internal.buildRustCrateWithFeatures {
-        packageId = "nix-cli";
-      };
-
-      # Debug support which might change between releases.
-      # File a bug if you depend on any for non-debug work!
-      debug = internal.debugCrate { inherit packageId; };
-    };
     "nix-compat" = rec {
       packageId = "nix-compat";
       build = internal.buildRustCrateWithFeatures {
@@ -4607,41 +4597,6 @@ rec {
         };
         resolvedDefaultFeatures = [ "feature" "fs" "user" ];
       };
-      "nix-cli" = rec {
-        crateName = "nix-cli";
-        version = "0.1.0";
-        edition = "2021";
-        crateBin = [
-          {
-            name = "nix-cli";
-            path = "src/main.rs";
-            requiredFeatures = [ ];
-          }
-          {
-            name = "nix-store";
-            path = "src/bin/nix-store.rs";
-            requiredFeatures = [ ];
-          }
-        ];
-        # We can't filter paths with references in Nix 2.4
-        # See https://github.com/NixOS/nix/issues/5410
-        src =
-          if ((lib.versionOlder builtins.nixVersion "2.4pre20211007") || (lib.versionOlder "2.5" builtins.nixVersion))
-          then lib.cleanSourceWith { filter = sourceFilter; src = ./nix_cli; }
-          else ./nix_cli;
-        dependencies = [
-          {
-            name = "clap";
-            packageId = "clap 4.2.7";
-          }
-          {
-            name = "tempfile";
-            packageId = "tempfile";
-          }
-        ];
-        features = { };
-        resolvedDefaultFeatures = [ "integration_tests" ];
-      };
       "nix-compat" = rec {
         crateName = "nix-compat";
         version = "0.1.0";