about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorConnor Brewster <cbrewster@hey.com>2023-10-14T16·58-0500
committerConnor Brewster <cbrewster@hey.com>2023-10-14T18·56+0000
commite3d72cc4cb6714f683e97e8405f296977335efa6 (patch)
treef02f6ea7a1373d1f87e53431f6d9bf8cdd2072d1 /tvix/Cargo.nix
parent8e811fe62536a45b15e4333a0542d60dbbc74f43 (diff)
refactor(tvix/store): Upgrade tokio-listener to get tonic support r/6810
Tonic support was added to tokio-listener upstream which removes the
need for use to have tonic compatibility wrapper types around it.

See: https://github.com/vi/tokio-listener/pull/2

Fixes b/311

Change-Id: I04a2dbb3bc3c8bfe9339583c0b46070c7ec97811
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9721
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 11d6e0ac7e..8848a3fe15 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -7481,9 +7481,9 @@ rec {
       };
       "tokio-listener" = rec {
         crateName = "tokio-listener";
-        version = "0.2.1";
+        version = "0.2.2";
         edition = "2021";
-        sha256 = "1yx7vsiwqg0lzdwyavwwnnpkvnmlgsjivvwsqbz7k9jj00lmx1q5";
+        sha256 = "0iaxcxbjhl2dk6b0w2bwm7qiryp119zgdhgqma169kmncn2xg7k6";
         dependencies = [
           {
             name = "document-features";
@@ -7523,6 +7523,11 @@ rec {
             features = [ "net" "io-std" "time" "sync" ];
           }
           {
+            name = "tonic";
+            packageId = "tonic";
+            optional = true;
+          }
+          {
             name = "tracing";
             packageId = "tracing";
           }
@@ -7538,6 +7543,10 @@ rec {
             packageId = "tokio";
             features = [ "macros" "rt" "io-util" ];
           }
+          {
+            name = "tonic";
+            packageId = "tonic";
+          }
         ];
         features = {
           "clap" = [ "dep:clap" ];
@@ -7549,10 +7558,12 @@ rec {
           "serde_with" = [ "dep:serde_with" ];
           "socket2" = [ "dep:socket2" ];
           "socket_options" = [ "socket2" ];
+          "tonic" = [ "dep:tonic" ];
+          "tonic010" = [ "tonic" ];
           "unix_path_tools" = [ "nix" ];
           "user_facing_default" = [ "inetd" "unix" "unix_path_tools" "sd_listen" "socket_options" ];
         };
-        resolvedDefaultFeatures = [ "default" "hyper" "hyper014" "inetd" "nix" "sd_listen" "socket2" "socket_options" "unix" "unix_path_tools" "user_facing_default" ];
+        resolvedDefaultFeatures = [ "default" "hyper" "hyper014" "inetd" "nix" "sd_listen" "socket2" "socket_options" "tonic" "tonic010" "unix" "unix_path_tools" "user_facing_default" ];
       };
       "tokio-macros" = rec {
         crateName = "tokio-macros";
@@ -9003,6 +9014,7 @@ rec {
           {
             name = "tokio-listener";
             packageId = "tokio-listener";
+            features = [ "tonic010" ];
           }
           {
             name = "tokio-stream";