about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-08T11·33+0200
committerclbot <clbot@tvl.fyi>2023-10-08T22·50+0000
commitb6bf3a87f162be158fea1386de1ee87a53c4d65b (patch)
tree30e107ca8dbf80c8fd6321082f65958e0e0fc974 /tvix/Cargo.nix
parentc0376995c9ac4e4b9ca606219035e808fe815d69 (diff)
test(tvix/castore): use tokio-retry for exp backoff r/6742
Rather than using this loop, use exponential backoff while waiting for
the socket path to be created.

Change-Id: I18706a64ce06f8916a07892dfbcd409ac5b3bff1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9568
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 7c98171a35..68ec9b5452 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -7182,6 +7182,38 @@ rec {
         ];
 
       };
+      "tokio-retry" = rec {
+        crateName = "tokio-retry";
+        version = "0.3.0";
+        edition = "2018";
+        sha256 = "0kr1hnm5dmb9gfkby88yg2xj8g6x4i4gipva0c8ca3xyxhvfnmvz";
+        authors = [
+          "Sam Rijs <srijs@airpost.net>"
+        ];
+        dependencies = [
+          {
+            name = "pin-project";
+            packageId = "pin-project";
+          }
+          {
+            name = "rand";
+            packageId = "rand";
+          }
+          {
+            name = "tokio";
+            packageId = "tokio";
+            features = [ "time" ];
+          }
+        ];
+        devDependencies = [
+          {
+            name = "tokio";
+            packageId = "tokio";
+            features = [ "full" ];
+          }
+        ];
+
+      };
       "tokio-stream" = rec {
         crateName = "tokio-stream";
         version = "0.1.14";
@@ -8127,6 +8159,10 @@ rec {
             name = "test-case";
             packageId = "test-case";
           }
+          {
+            name = "tokio-retry";
+            packageId = "tokio-retry";
+          }
         ];
         features = {
           "tonic-reflection" = [ "dep:tonic-reflection" ];