about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-08T11·40+0200
committerclbot <clbot@tvl.fyi>2023-10-08T22·50+0000
commita464088d2e3cc9bb0ff7a432d592157a811ef6c8 (patch)
tree6bc98f4e4f8b2eeb7a1631096d985984bc0d1d95 /tvix/Cargo.nix
parentb6bf3a87f162be158fea1386de1ee87a53c4d65b (diff)
test(tvix/store): use tokio-retry for exp backoff r/6743
Rather than using this loop, use exponential backoff while waiting for
the socket path to be created.

Change-Id: I3056b1525784cd712b1d81f84876c9ca0be10dc6
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9569
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 68ec9b5452..868620b76a 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -8634,6 +8634,10 @@ rec {
             name = "test-case";
             packageId = "test-case";
           }
+          {
+            name = "tokio-retry";
+            packageId = "tokio-retry";
+          }
         ];
         features = {
           "default" = [ "fuse" "tonic-reflection" ];