about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-02T13·37+0100
committerflokli <flokli@flokli.de>2023-01-03T13·03+0000
commitceb2c0ba895554c7cabb0ac20d3a80ea2aba1ab1 (patch)
tree427ee29cd8883bc1159a58e7f6e92a8d673b155e /tvix/Cargo.nix
parentd0bbc8c8214fe164be572a0c2b1bd28f79fc1d20 (diff)
chore(tvix/store): make importable r/5569
This allows other crates to import tvix_store.

Rename the bin crate to tvix-store-bin, to avoid having multiple crates
with the same name (https://github.com/rust-lang/cargo/issues/6313)

Change-Id: I857768d6115640dbf102e79ed03e8474090df2fe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7728
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 361a0a3ee0..d96632e053 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -103,10 +103,10 @@ rec {
       # File a bug if you depend on any for non-debug work!
       debug = internal.debugCrate { inherit packageId; };
     };
-    "tvix-store" = rec {
-      packageId = "tvix-store";
+    "tvix-store-bin" = rec {
+      packageId = "tvix-store-bin";
       build = internal.buildRustCrateWithFeatures {
-        packageId = "tvix-store";
+        packageId = "tvix-store-bin";
       };
 
       # Debug support which might change between releases.
@@ -6641,13 +6641,13 @@ rec {
         ];
 
       };
-      "tvix-store" = rec {
-        crateName = "tvix-store";
+      "tvix-store-bin" = rec {
+        crateName = "tvix-store-bin";
         version = "0.1.0";
         edition = "2021";
         crateBin = [
           {
-            name = "tvix-store";
+            name = "tvix-store-bin";
             path = "src/main.rs";
             requiredFeatures = [ ];
           }
@@ -6658,6 +6658,7 @@ rec {
           if (lib.versionOlder builtins.nixVersion "2.4pre20211007")
           then lib.cleanSourceWith { filter = sourceFilter; src = ./store; }
           else ./store;
+        libName = "tvix_store";
         dependencies = [
           {
             name = "anyhow";