about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-21T13·18+0100
committerflokli <flokli@flokli.de>2023-01-21T15·12+0000
commit1a84e3e6d800fed1709364174d4a615b1d146ad0 (patch)
treee08cddc3d30c4796402ecc70c3c637b11f322f4c /tvix/Cargo.nix
parent4614db2f83b42f6026beee9fa60d36aabec2e3de (diff)
chore(tvix/store): add fastcdc crate r/5727
This is used for content-defined chunking.

Change-Id: I10345372cecb9a643cc51ca45aa5b77d2a05198a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7889
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index f81af2a058..c360f7293d 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -1806,6 +1806,16 @@ rec {
         ];
         features = { };
       };
+      "fastcdc" = rec {
+        crateName = "fastcdc";
+        version = "2.0.0";
+        edition = "2018";
+        sha256 = "1cbjm24yq0rpykb0lp4s5w4hvixj0k3m10w95sncd62h784ax4w0";
+        authors = [
+          "Nathan Fiedler <nathanfiedler@fastmail.fm>"
+        ];
+
+      };
       "fastrand" = rec {
         crateName = "fastrand";
         version = "1.8.0";
@@ -7363,6 +7373,10 @@ rec {
             packageId = "data-encoding";
           }
           {
+            name = "fastcdc";
+            packageId = "fastcdc";
+          }
+          {
             name = "lazy_static";
             packageId = "lazy_static";
           }