about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2022-12-27T16·41+0100
committerflokli <flokli@flokli.de>2022-12-27T21·31+0000
commit35b18b2fdb986aabc1ca22a48c203e2358b1b23e (patch)
tree5bb28940b4900254611c87db6922bb51ff203e0a /tvix/Cargo.nix
parentdfd9286f680ef69ff89ab9a9081b2beaabda92be (diff)
chore(tvix/store): use lazy_static and dummy digests r/5510
While there's currently nothing in here checking the size of the digest,
we should use something that passes the to-be-introduced validate()
function.

Change-Id: I0c515d9e3afc79292dedebce659a32485aa3d936
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7649
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 8ef5370268..8076dd2c4a 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -6168,6 +6168,10 @@ rec {
             features = [ "rayon" "std" ];
           }
           {
+            name = "lazy_static";
+            packageId = "lazy_static";
+          }
+          {
             name = "prost";
             packageId = "prost";
           }