about summary refs log tree commit diff
path: root/tools/website-blocker/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-28T19·36+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-28T19·36+0000
commit37bb04eb5d7c9ccd77926f107ca685039a010e43 (patch)
treef2e5dc3cb330c62741422ef8436f2845d125d6e4 /tools/website-blocker/shell.nix
parent778114e6a8930017b82ed8c1a68240a534a1bef5 (diff)
Start social-fasting app
I'd like to ensure that my /etc/hosts file blocks websites at certains times. I
use this to allow / disallow websites at various times of the day.

TODO:
- Add project README
- Add tests
- Publish
- Create a Nix derivation
- Run as a systemd timer unit
- Figure out if I can run this as a user rather than root
Diffstat (limited to 'tools/website-blocker/shell.nix')
-rw-r--r--tools/website-blocker/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/website-blocker/shell.nix b/tools/website-blocker/shell.nix
new file mode 100644
index 000000000000..fd1889dd891f
--- /dev/null
+++ b/tools/website-blocker/shell.nix
@@ -0,0 +1,7 @@
+let
+  pkgs = import <nixpkgs> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    ghc
+  ];
+}