about summary refs log tree commit diff
path: root/tools/url-blocker/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-18T11·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit0c71fc9d1d49daa914c0f56f4f9201d40415d9b4 (patch)
tree3c8a4b894065e64111c20d06026b63db17259c65 /tools/url-blocker/shell.nix
parent51ec9e0d88b15276ec0891f932f6b572d6450809 (diff)
Drop support for dir-locals.nix, <nixpkgs>, etc.
In the spirit of Marie Kondo, I'm tidying up!

TL;DR:
- Prefer .envrc `use_nix` and delete all dir-locals.nix files
- Remove ~all references to <nixpkgs>, <unstable>, <depot> and prefer
  referencing each with briefcase.third_party.{pkgs,unstable,depot}
- Delete nixBufferFromShell function since I was only using that in
  dir-locals.nix files
Diffstat (limited to 'tools/url-blocker/shell.nix')
-rw-r--r--tools/url-blocker/shell.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/tools/url-blocker/shell.nix b/tools/url-blocker/shell.nix
index 40f217e3f9a7..1adc566c0121 100644
--- a/tools/url-blocker/shell.nix
+++ b/tools/url-blocker/shell.nix
@@ -1,12 +1,10 @@
 let
-  pkgs = import <unstable> {};
-in pkgs.mkShell {
-  buildInputs = with pkgs; [
-    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
-      time
-      aeson
-      either
-      hspec
-    ]))
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    time
+    aeson
+    either
+    hspec
   ];
 }