about summary refs log tree commit diff
path: root/tools/url-blocker/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-29T19·35+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-03-29T19·39+0100
commit946764f6bd8dc8a4c9653e0b148ed96d95aabd9c (patch)
treef47a7189a73968c77883eb46958b3c55865390b9 /tools/url-blocker/shell.nix
parent75595b0126806e1f1f35802ec534e32492cb2a6c (diff)
Read and write to /etc/hosts
TL;DR:
- Rename website-blocker to url-blocker
- Add a README.md
- Reads and writes to /etc/hosts
Diffstat (limited to 'tools/url-blocker/shell.nix')
-rw-r--r--tools/url-blocker/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/url-blocker/shell.nix b/tools/url-blocker/shell.nix
new file mode 100644
index 000000000000..40f217e3f9a7
--- /dev/null
+++ b/tools/url-blocker/shell.nix
@@ -0,0 +1,12 @@
+let
+  pkgs = import <unstable> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+      time
+      aeson
+      either
+      hspec
+    ]))
+  ];
+}