about summary refs log tree commit diff
path: root/tools/url-blocker/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-02T12·28+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-02T12·28+0100
commite4ddc3ba75f75b6df0d11ccc62b75a346d0e3846 (patch)
treec2cac178e1085a9500f3b2d32fcab2058931d0f7 /tools/url-blocker/default.nix
parent155dff562ac5c9d893ace858c4a41a2d89955097 (diff)
Prefer builtins.path
Thanks to the Nix anti-patterns documented here...

https://nix.dev/anti-patterns/language.html#reproducability-referencing-top-level-directory-with

...I'm cleaning up some of my Nix expressions. Read the article for more
context.
Diffstat (limited to 'tools/url-blocker/default.nix')
-rw-r--r--tools/url-blocker/default.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/url-blocker/default.nix b/tools/url-blocker/default.nix
index d6a098851b..5d1b8cd166 100644
--- a/tools/url-blocker/default.nix
+++ b/tools/url-blocker/default.nix
@@ -12,9 +12,7 @@ let
   # This is the systemd service unit
   service = pkgs.stdenv.mkDerivation {
     name = "url-blocker";
-    src = ./.;
-    buildInputs = with pkgs; [
-    ];
+    src = builtins.path { path = ./.; name = "url-blocker"; };
     buildPhase = ''
     ${ghc}/bin/ghc Main.hs
   '';