about summary refs log tree commit diff
path: root/tools/nixery/docs/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-04T21·45+0100
committerVincent Ambo <github@tazj.in>2019-08-04T23·32+0100
commit2bef0ba2403f20826fbd615b0abb91cb2aff0350 (patch)
tree701e593ef37ef96b029fb05ebb7646e8c8a964f1 /tools/nixery/docs/default.nix
parent85e8d760fcf16e50ba8e055561ac418f4f5bce58 (diff)
feat(build): Build Nixery book and embed it into Nixery image
Executes the previously added mdBook on the previously added book
source to yield a directory that can be served by Nixery on its index
page.

This is one of those 'I <3 Nix' things due to how easy it is to do.
Diffstat (limited to 'tools/nixery/docs/default.nix')
-rw-r--r--tools/nixery/docs/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/nixery/docs/default.nix b/tools/nixery/docs/default.nix
new file mode 100644
index 0000000000..ba652cef9c
--- /dev/null
+++ b/tools/nixery/docs/default.nix
@@ -0,0 +1,36 @@
+# Copyright 2019 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Builds the documentation page using the Rust project's 'mdBook'
+# tool.
+#
+# Some of the documentation is pulled in and included from other
+# sources.
+
+{ fetchFromGitHub, mdbook, runCommand }:
+
+let
+  nix-1p = fetchFromGitHub {
+    owner  = "tazjin";
+    repo   = "nix-1p";
+    rev    = "aab846cd3d79fcd092b1bfea1346c587b2a56095";
+    sha256 = "12dl0xrwgg2d4wyv9zxgdn0hzqnanczjg23vqn3356rywxlzzwak";
+  };
+in runCommand "nixery-book" {} ''
+  mkdir -p $out
+  cp -r ${./.}/* .
+  chmod -R a+w src
+  cp ${nix-1p}/README.md src/nix-1p.md
+  ${mdbook}/bin/mdbook build -d $out
+''