about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-08-19T00·10+0100
committerVincent Ambo <github@tazj.in>2019-08-19T00·56+0100
commite7d7f73f7d191c4149409a0be83c924127972b2a (patch)
tree87c5b070c88301baa6ae51f375b414b456389152 /tools/nixery/default.nix
parentffae282eac86f4df48a5c39f61d82dd88ccca1ec (diff)
feat(build): Add 'extraPackages' parameter
This makes it possible to inject additional programs (e.g. Cachix)
into a Nixery container.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 194cf54608..31b15396a5 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -11,7 +11,9 @@
 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 # See the License for the specific language governing permissions and
 # limitations under the License.
-{ pkgs ? import <nixpkgs> { }, preLaunch ? "" }:
+{ pkgs ? import <nixpkgs> { }
+, preLaunch ? ""
+, extraPackages ? [] }:
 
 with pkgs;
 
@@ -93,6 +95,6 @@ rec {
       nixery-launch-script
       openssh
       zlib
-    ];
+    ] ++ extraPackages;
   };
 }