about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-10-11T12·55+0100
committerVincent Ambo <github@tazj.in>2019-10-11T13·23+0100
commitcca835ae37cc35f3cae80afe5af8049009a6aa89 (patch)
tree64799be3989bfc07ee086285b3ae344be7d284a1 /tools/nixery/default.nix
parent1853c74998953048478b8526f408f8c57b129958 (diff)
fix(build): Only take the first matching hash for source hashing
Some Nix download mechanisms will add a second hash in the store path,
which had been added to the source hash output (breaking argument
interpolation).
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 20a5b50220..422148d626 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -23,7 +23,7 @@ rec {
   # builds to distinguish errors between deployed versions, see
   # server/logs.go for details.
   nixery-src-hash = pkgs.runCommand "nixery-src-hash" {} ''
-    echo ${./.} | grep -Eo '[a-z0-9]{32}' > $out
+    echo ${./.} | grep -Eo '[a-z0-9]{32}' | head -c 32 > $out
   '';
 
   # Go implementation of the Nixery server which implements the