about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-07-30T23·39+0100
committerVincent Ambo <github@tazj.in>2019-07-31T14·28+0100
commita83701a14b4b620d9b24656e638d31e746f3a06e (patch)
treeaf7158f2140e8c93075fcd9aeb987925f12630c8 /tools/nixery/default.nix
parent2e4b1f85eef04c0abd83f5f47e1aa93c8ea84cb9 (diff)
feat(build): Add dependencies for custom repo clones
Adds git & SSH as part of the Nixery image, which are required to use
Nix's builtins.fetchGit.

The dependency on interactive tools is dropped, as it was only
required during development when debugging the image building process
itself.
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 23c776e117..0f28911668 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -94,13 +94,13 @@ rec {
     name = "nixery";
     config.Cmd = ["${nixery-launch-script}/bin/nixery"];
     contents = [
-      bashInteractive
       cacert
-      coreutils
-      nix
-      nixery-launch-script
+      git
       gnutar
       gzip
+      nix
+      nixery-launch-script
+      openssh
     ];
   };
 }