about summary refs log tree commit diff
path: root/tools/monzo_ynab/tokens.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-20T09·15+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-20T09·15+0100
commit5add8ddc13be3a7a5fbb6deb3f70cb18594f8750 (patch)
treebd36fd690f6765e6a270b7ad71fe3bf7a4266091 /tools/monzo_ynab/tokens.nix
parent4ed3254709263abf3aaa1e9469968c6be9615948 (diff)
Move monzo_ynab into //tools
Optimizing is difficult: I like flat hierarchies because I don't like
directory-hopping, but I also would like a cleaner root for my mono-repo. Bombs
away!

Well it's that time again, folks: spring cleaning!

Here I am musing about a few things that bother me:
- Should I use kebab-case or snake_case?
- It feels ~confusing to have //tools and //utils. What a //projects? Isn't
  everything a project? *sigh*
Diffstat (limited to 'tools/monzo_ynab/tokens.nix')
-rw-r--r--tools/monzo_ynab/tokens.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/monzo_ynab/tokens.nix b/tools/monzo_ynab/tokens.nix
new file mode 100644
index 000000000000..97de09d741e9
--- /dev/null
+++ b/tools/monzo_ynab/tokens.nix
@@ -0,0 +1,23 @@
+{ depot, briefcase, ... }:
+
+let
+  auth = depot.buildGo.package {
+    name = "auth";
+    srcs = [
+      ./auth.go
+    ];
+    deps = with briefcase.gopkgs; [
+      utils
+    ];
+  };
+in depot.buildGo.program {
+  name = "token-server";
+  srcs = [
+    ./tokens.go
+  ];
+  deps = with briefcase.gopkgs; [
+    kv
+    utils
+    auth
+  ];
+}