about summary refs log tree commit diff
path: root/tools/gotest/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
commit03bfe08e1dd9faf48b06cb146bfa446575cde88a (patch)
tree55317968922a9b2a01516f1b79527874df037517 /tools/gotest/default.nix
parente52eed3cd4f73779c2e7c350537fb346835ba9f3 (diff)
chore: Significantly restructure folder layout r/237
This moves the various projects from "type-based" folders (such as
"services" or "tools") into more appropriate semantic folders (such as
"nix", "ops" or "web").

Deprecated projects (nixcon-demo & gotest) which only existed for
testing/demonstration purposes have been removed.

(Note: *all* builds are broken with this commit)
Diffstat (limited to 'tools/gotest/default.nix')
-rw-r--r--tools/gotest/default.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/tools/gotest/default.nix b/tools/gotest/default.nix
deleted file mode 100644
index 168d15748e..0000000000
--- a/tools/gotest/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-# This file demonstrates how to make use of pkgs.buildGo.
-#
-# It introduces libraries and protobuf support, however gRPC support
-# is not yet included.
-#
-# From the root of this repository this example can be built with
-# `nix-build -A tools.gotest`
-{ pkgs, ... }:
-
-let
-  inherit (pkgs) buildGo;
-
-  somelib = buildGo.package {
-    name = "somelib";
-    srcs = [ ./lib.go ];
-  };
-
-  someproto = buildGo.proto {
-    name = "someproto";
-    proto = ./test.proto;
-  };
-
-in buildGo.program {
-  name = "gotest";
-  srcs = [ ./main.go ];
-  deps = [ somelib someproto ];
-} // { meta.enableCI = true; }