about summary refs log tree commit diff
path: root/tools/gotest/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-22T16·28+0000
committerVincent Ambo <tazjin@google.com>2019-11-22T16·28+0000
commit1619f58d782ae4de67a056757efbbdc91ce30367 (patch)
tree4b1e79ff9e976d8082747d79bb5212092f89f357 /tools/gotest/default.nix
parent9ea0363e6f34a9f41b3c849359c97f06dbec2b9f (diff)
feat(tools): Add 'gotest' program to demonstrate pkgs.buildGo
This is a tiny program that does nothing but exists to demonstrate
pkgs.buildGo by building a program that depends on a local library as
well as a protobuf definition.
Diffstat (limited to 'tools/gotest/default.nix')
-rw-r--r--tools/gotest/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/gotest/default.nix b/tools/gotest/default.nix
new file mode 100644
index 0000000000..4396cd9b47
--- /dev/null
+++ b/tools/gotest/default.nix
@@ -0,0 +1,27 @@
+# This file demonstrates how to make use of pkgs.buildGo.
+#
+# It introduces libraries and protobuf support, however gRPC support
+# is not yet included.
+#
+# From the root of this repository this example can be built with
+# `nix-build -A tools.gotest`
+{ pkgs, ... }:
+
+let
+  inherit (pkgs) buildGo;
+
+  somelib = buildGo.package {
+    name = "somelib";
+    srcs = [ ./lib.go ];
+  };
+
+  someproto = buildGo.proto {
+    name = "someproto";
+    proto = ./test.proto;
+  };
+
+in buildGo.program {
+  name = "gotest";
+  srcs = [ ./main.go ];
+  deps = [ somelib someproto ];
+}