about summary refs log tree commit diff
path: root/tools/emacs-pkgs/term-switcher/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-15T22·53+0000
committerVincent Ambo <tazjin@google.com>2019-12-15T22·54+0000
commitf34c82f7654ad2c751524095b389c39343ab828b (patch)
tree6020b4c133e03f653e6ade6abc6ba9a99f86754e /tools/emacs-pkgs/term-switcher/default.nix
parent9f8542fe75e5d4c166316983093e26e37bdd332d (diff)
refactor(emacs-pkgs): Extract term-switcher into separate emacs pkg
Diffstat (limited to 'tools/emacs-pkgs/term-switcher/default.nix')
-rw-r--r--tools/emacs-pkgs/term-switcher/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/emacs-pkgs/term-switcher/default.nix b/tools/emacs-pkgs/term-switcher/default.nix
new file mode 100644
index 0000000000..ad96638a05
--- /dev/null
+++ b/tools/emacs-pkgs/term-switcher/default.nix
@@ -0,0 +1,14 @@
+{ pkgs, ... }:
+
+with pkgs.third_party.emacsPackagesNg;
+
+melpaBuild rec {
+  pname = "term-switcher";
+  version = "1.0";
+  src = ./term-switcher.el;
+  packageRequires = [ dash ivy s ];
+
+  recipe = builtins.toFile "recipe" ''
+    (term-switcher :fetcher github :repo "tazjin/depot")
+  '';
+}