about summary refs log tree commit diff
path: root/tools/eaglemode/plugins/example.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2024-08-28T14·59+0300
committerclbot <clbot@tvl.fyi>2024-09-02T12·58+0000
commit18578c3458187bad901ce559131922e856162fb5 (patch)
tree905118fd92ddc4020ce0e95274694d26c200523e /tools/eaglemode/plugins/example.nix
parent3abc104584b1fbc92199a7d54caddbe8065b637e (diff)
feat(tools/eaglemode): add plugin builder for eagle mode r/8637
Adds a buildPlugin function which can build Eagle Mode plugins that can
ultimately be linked into Eagle Mode using the existing etcDir function.

Change-Id: I338171779d3547faecbfb708fbaa78cd1cfd59ac
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12387
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Reviewed-by: emery <emery@dmz.rs>
Reviewed-by: azahi <azat@bahawi.net>
Diffstat (limited to 'tools/eaglemode/plugins/example.nix')
-rw-r--r--tools/eaglemode/plugins/example.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/eaglemode/plugins/example.nix b/tools/eaglemode/plugins/example.nix
new file mode 100644
index 000000000000..b361971cc57e
--- /dev/null
+++ b/tools/eaglemode/plugins/example.nix
@@ -0,0 +1,17 @@
+{ depot, pkgs, ... }:
+
+let
+  em = depot.tools.eaglemode;
+  emSrc = with pkgs; srcOnly eaglemode;
+in
+em.buildPlugin {
+  name = "example";
+  version = "canon";
+
+  src = pkgs.runCommand "em-plugin-example-src" { } ''
+    set -ux
+    cp -r ${emSrc}/doc/examples/CppApiExamples/PluginExample $out
+  '';
+
+  target = "PlEx";
+}