about summary refs log tree commit diff
path: root/tools/depot-scanner/default.nix
diff options
context:
space:
mode:
authorKane York <kanepyork@gmail.com>2020-08-10T22·13-0700
committerkanepyork <rikingcoding@gmail.com>2020-08-20T03·05+0000
commitdfc351b4634aff4c56a08ab4f47139ccaf6dc652 (patch)
tree9f0c6e05461c86dab954b16befe78eb801f9d3b7 /tools/depot-scanner/default.nix
parent50b200f21abec83e7d7934780526a3aae84ed0ef (diff)
feat(tools/depot-scanner): init project r/1683
depot-scanner is a tool that runs Nix and parses the --trace-file-access output to deduce what files are necessary to evaluate a derivation.

Take DEPOT_ROOT from the environment. If depotRoot doesn't exist, print an error early.

Fix the build of the protobuf library. Switch to the GRPC build rule, as a service is in this proto file.

Create the PathType enum and parse it from cmdline flags.

Change-Id: I537b5c6bceecf76ca510f7ac04ab9dad7785feb1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1769
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'tools/depot-scanner/default.nix')
-rw-r--r--tools/depot-scanner/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/depot-scanner/default.nix b/tools/depot-scanner/default.nix
new file mode 100644
index 0000000000..d18034cff0
--- /dev/null
+++ b/tools/depot-scanner/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ...}:
+
+let
+  localProto = depot.nix.buildGo.grpc {
+    name = "code.tvl.fyi/tools/depot-scanner/proto";
+    proto = ./depot_scanner.proto;
+  };
+in depot.nix.buildGo.program {
+  name = "depot-scanner";
+  srcs = [
+    ./main.go
+  ];
+  deps = [
+    localProto
+  ];
+} // { inherit localProto; }