about summary refs log tree commit diff
path: root/tools/cheddar/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-21T14·09+0000
committerVincent Ambo <tazjin@google.com>2019-12-21T14·09+0000
commitd35aa4ae46083e1655506749760fd87ff954c205 (patch)
treeefa2c56436cd6c14d0ffc5988c5aba71dbf31b7d /tools/cheddar/Cargo.toml
parenteb650eb8d8cb0af11666d970c91f32b51211de11 (diff)
refactor(cheddar): Set up scaffolding for Markdown rendering r/281
Generalises the two bits of the program that will be required either
way (extension parsing and syntax loading).

A dependency on Comrak is introduced as I think GitHub-flavoured
Markdown (with all its fancy extensions) is desirable!
Diffstat (limited to 'tools/cheddar/Cargo.toml')
-rw-r--r--tools/cheddar/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/cheddar/Cargo.toml b/tools/cheddar/Cargo.toml
index 1ce121c025..fe936deb4c 100644
--- a/tools/cheddar/Cargo.toml
+++ b/tools/cheddar/Cargo.toml
@@ -4,5 +4,7 @@ version = "0.1.0"
 authors = ["Vincent Ambo <mail@tazj.in>"]
 edition = "2018"
 
-[dependencies.syntect]
-version = "3.3"
+[dependencies]
+comrak = "0.6"
+lazy_static = "1.4"
+syntect = "3.3"