about summary refs log tree commit diff
path: root/tools/cheddar/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-20T01·57+0100
committertazjin <mail@tazj.in>2020-06-20T02·59+0000
commite27b0a3013da6cb017850751280c4a3f314740aa (patch)
tree3cf5bd6c6893e1da93d601e3f57ea6e40370b79a /tools/cheddar/Cargo.toml
parentb8251556c6decffe7a64433bbfa7a7dd2001db4c (diff)
feat(cheddar): Add Sourcegraph-compatible highlighting server r/1044
Sourcegraph uses a component called syntect_server to syntax-highlight
source files.

Since we already have custom syntaxes, overrides and configuration we
might as well use them with Sourcegraph!

This implements the syntect_server "protocol" (it's just a single
endpoint) so that we can swap out the syntect_server component with
cheddar.

Note: There's a few clippy lints here, but they're being solved in a
followup commit because I wanted to take care of all of them at
once (not just the ones introduced in this change).

Change-Id: Ib518a2fa1b9fee299fe599482403599583cac479
Reviewed-on: https://cl.tvl.fyi/c/depot/+/509
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'tools/cheddar/Cargo.toml')
-rw-r--r--tools/cheddar/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/cheddar/Cargo.toml b/tools/cheddar/Cargo.toml
index b7d9a77586..66830e67d6 100644
--- a/tools/cheddar/Cargo.toml
+++ b/tools/cheddar/Cargo.toml
@@ -5,7 +5,13 @@ authors = ["Vincent Ambo <mail@tazj.in>"]
 edition = "2018"
 
 [dependencies]
+clap = "2.33"
 comrak = "0.7"
 lazy_static = "1.4"
+rouille = "3.0"
 syntect = "4.2.0"
-clap = "2.33"
+serde_json = "1.0"
+
+[dependencies.serde]
+version = "1.0"
+features = [ "derive" ]