about summary refs log tree commit diff
path: root/tools/aoc2019/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
commit03bfe08e1dd9faf48b06cb146bfa446575cde88a (patch)
tree55317968922a9b2a01516f1b79527874df037517 /tools/aoc2019/default.nix
parente52eed3cd4f73779c2e7c350537fb346835ba9f3 (diff)
chore: Significantly restructure folder layout r/237
This moves the various projects from "type-based" folders (such as
"services" or "tools") into more appropriate semantic folders (such as
"nix", "ops" or "web").

Deprecated projects (nixcon-demo & gotest) which only existed for
testing/demonstration purposes have been removed.

(Note: *all* builds are broken with this commit)
Diffstat (limited to 'tools/aoc2019/default.nix')
-rw-r--r--tools/aoc2019/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/tools/aoc2019/default.nix b/tools/aoc2019/default.nix
deleted file mode 100644
index a53586eea9eb..000000000000
--- a/tools/aoc2019/default.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-# Solutions for Advent of Code 2019, written in Emacs Lisp.
-#
-# For each day a new file is created as "solution-day$n.el".
-{ pkgs, ... }:
-
-let
-  inherit (builtins) attrNames filter head listToAttrs match readDir;
-  dir = readDir ./.;
-  matchSolution = match "solution-(.*)\.el";
-  isSolution = f: (matchSolution f) != null;
-  getDay = f: head (matchSolution f);
-
-  solutionFiles = filter (e: dir."${e}" == "regular" && isSolution e) (attrNames dir);
-  solutions = map (f: let day = getDay f; in {
-    name = day;
-    value = pkgs.writeElispBin {
-      name = "aoc2019";
-      deps = p: with p; [ dash s ht ];
-      src = ./. + ("/" + f);
-    };
-  }) solutionFiles;
-in listToAttrs solutions